[Gelöst] Anet A8 überfährt Y Endschalter

Bereich für alle Prusa und prusa-ähnlichen Maschinen!
Antworten
Matthew-S
Neuling
Beiträge: 2
Registriert: Mi 23. Jan 2019, 19:26
Drucker: Anet A8
Slicer: Cura
CAD - Software: div
Hat sich bedankt: 0
Danksagung erhalten: 0

[Gelöst] Anet A8 überfährt Y Endschalter

#1

Beitrag von Matthew-S » So 22. Sep 2019, 13:02

Hallo Zusammen,

ich bin nun seit ca. 2 Jahren besitzer des Anet A8 und immernoch im Optimierungsprozess. (Hab leider nicht so oft Zeit dafür)
Ich habe seit ein paar Tagen ein Problem mit dem Drucker:

Beim Homing (beim Drucken einer Datei von SD-Card oder auch über manuell über das Menü angestoßen) fährt der Drucker die Endschalter der einzelnen Achsen an, bei X- und Z-Achse alles wie gewohnt. Bei der Y-Achse aber fährt er gegen den Endschalter und der Motor dreht noch einige sekunden weiter, dann fährt er wie gewohnt wieder vom Endschalter zurück und will den Nullpunkt nochmal anfahren. Auch dabei läuft er wieder über den Endschalter hinaus und der Motor dreht einen kurzen Moment durch.

Ich habe den Schalter am Stecker durchgemessen, der ist Okay. Auch auf dem Stecker am Board liegen 5V an. Habe mir dann mal per Terminal die Statusmeldungen der Endschalter angschaut. Mit dem Befehl "M119" der Controler erkennt hier die Zustände offen und geschlossen wie ich es erwarten würde.

Anhand dieser Informationen schließe ich einen fehler in der Slicer-Software eigentlich aus. Sehe ich das richtig?

Hat jemand eine Idee wo der Fehler liegt? ich würde jetzt auf die Firmware des Druckers schließen, aber die habe ich nicht verändert.

Für Hinweise wäre ich dankbar!
Gruß, Matthew

Benutzeravatar
Borg
Silver - Mitglied
Beiträge: 519
Registriert: Mo 14. Aug 2017, 19:52
Drucker: Zaubermaschine
Hat sich bedankt: 1 Mal
Danksagung erhalten: 56 Mal

#2

Beitrag von Borg » So 22. Sep 2019, 13:20

Schau mal nach, ob der Endschalter richtig ausgerichtet ist. Es klingt etwas so, als würde das Bett den Schalter nicht richtig treffen.

Matthew-S
Neuling
Beiträge: 2
Registriert: Mi 23. Jan 2019, 19:26
Drucker: Anet A8
Slicer: Cura
CAD - Software: div
Hat sich bedankt: 0
Danksagung erhalten: 0

#3

Beitrag von Matthew-S » Di 24. Sep 2019, 14:20

Okay, hier mal die Rückmeldung. Im Endeffekt hattest du den richtigen Riecher. Ich habe zuletzt vor ein paar Wochen eine Versteifung gedruckt die den mittleren Rahmenteil gegen den Y-Motor abstützt. https://www.thingiverse.com/thing:2067872

Der Heizbett-Träger stößt aber nun oben am Y-Motor gegen den diese Versteifung. Habe den originalen Heizbett-Träger mal gegen einen "robusteren" ausgetauscht, designt ist die Abstützung anscheinend für den original Träger. Nun wurde der Endschalter gar nicht mehr betätigt.
Da ich das Ding einfach nach dem Druck ohne testen eingebaut hatte, aber dann mal wieder eine Pause einlegen musste, habe ich das nicht mit dem Fehler verknüpft.

Problem wurde also Identifiziert. -> mechanische Blockade. Jetzt muss ich die Stütze wohl noch etwas anpassen.

Danke für den schubs in die richtige Richtung. Gruß, Matthew

Antworten