Hotend Temperatur wird falsch angezeigt.

Modifikationen die für alle Anet- Drucker Typen passen.
Benutzeravatar
TrippleP
Honor Member
Beiträge: 63
Registriert: Mi 28. Feb 2018, 08:03
Drucker: AM8
Slicer: Cura 3.2.1
Hat sich bedankt: 23 Mal
Danksagung erhalten: 5 Mal

Hotend Temperatur wird falsch angezeigt.

Beitrag von TrippleP » Mi 9. Mai 2018, 15:09

Hallo zusammen,

An meinem AM8 habe ich ein Problem mit der Hotend Temperatur.

Es handelt sich um ein Standard A8 Board mit Marlin 1.1.8
Verbaut ist ein China clone eines E3D V6 Hotend.

Ich habe das Hotend zuerst mit der mitgelieferten Thermistorkartusche verkabelt und nach vorgabe als Typ 13 in Marlin angemeldet.
Das Ergebnis war eine Angezeigte Hotend Temp von 180°C aber gemessenen 140°C
Zum Vergleich habe ich den Thermistor vom MK8 Hotend aussen an den Heatblock gehalten und habe identische Temperaturen gemessen.
Gemessen habe ich am Block selber, an der klemmschraube der Thermistorkartusche und an der Düse.

Keine der anderen Thermistor typen führte zu einem besseren Ergbniss.

Um auf Nummer sicher zu gehen habe ich eine original E3D Thermistorkartusche bestellt.
Heute ist sie angekommen und was soll ich sagen... das gleiche Ergebnis Mit Sensor Typ5 laut E3D Website
Auch ein Tausch der Anschlüsse am Board bringt die gleichen Messwerte vom Thermistor.

Habe ich einen Denkfehler und es ist normal, das die temperatur aussen am Heatblock 30°C unter dem Kern liegt?
Habe ich irgendetwas übersehen?

Dank und Gruß



Benutzeravatar
lixxbox
Honor Member
Beiträge: 342
Registriert: Mi 25. Jan 2017, 15:12
Wohnort: Koblenz
Drucker: Bowden AM8+Octoprint
Slicer: Simplify3D
CAD - Software: Fusion360
Hat sich bedankt: 26 Mal
Danksagung erhalten: 59 Mal

Hotend Temperatur wird falsch angezeigt.

Beitrag von lixxbox » Mi 9. Mai 2018, 15:34

Geht denn Filament durch? Bei 140°C dürfte das ja nicht der Fall sein.



Benutzeravatar
TrippleP
Honor Member
Beiträge: 63
Registriert: Mi 28. Feb 2018, 08:03
Drucker: AM8
Slicer: Cura 3.2.1
Hat sich bedankt: 23 Mal
Danksagung erhalten: 5 Mal

Hotend Temperatur wird falsch angezeigt.

Beitrag von TrippleP » Mi 9. Mai 2018, 15:50

grad nochmal versucht, kommt nix, der titan knackt nur.



Benutzeravatar
lixxbox
Honor Member
Beiträge: 342
Registriert: Mi 25. Jan 2017, 15:12
Wohnort: Koblenz
Drucker: Bowden AM8+Octoprint
Slicer: Simplify3D
CAD - Software: Fusion360
Hat sich bedankt: 26 Mal
Danksagung erhalten: 59 Mal

Hotend Temperatur wird falsch angezeigt.

Beitrag von lixxbox » Mi 9. Mai 2018, 16:07

Das Material hast du sonst immer bei 180°C gedruckt?
Ich würde mal Schrittweise mit der Temperatur höher gehen, bis was rauskommt und dann deinen Temptower drucken.

Ansonsten wie im Chat bereits besprochen wurde mal den Widerstand der Thermistoren messen.
Du könntest das alte Hotend nochmal zusammenbauen und den gegentest machen, um z.B. das Mainboard auszuschließen.

Ob die Hitze außen am Block eine andere ist, weiß ich nicht. Würde da eher die Messmethoden anzweifeln (IR-Thermometer, Thermistor dranhalten).
Folgende Benutzer bedankten sich beim Autor lixxbox für den Beitrag:
TrippleP
Bewertung: 14.29%



Benutzeravatar
TrippleP
Honor Member
Beiträge: 63
Registriert: Mi 28. Feb 2018, 08:03
Drucker: AM8
Slicer: Cura 3.2.1
Hat sich bedankt: 23 Mal
Danksagung erhalten: 5 Mal

Hotend Temperatur wird falsch angezeigt.

Beitrag von TrippleP » Mi 9. Mai 2018, 16:23

Eben bei 29.9°C Raumtemperatur gemessen:

Thermistor
vom MK8: 79 kOhm
E3D: 78.9 kOhm
Trianglelabs: 78.0 kOhm

Das MK8 Hotend kann ich zwar zusammenbauen aber nicht montieren, der AM8 hat aktuell keine passende aufnahme und ich kann keine drucken :)
Zuletzt geändert von TrippleP am Mi 9. Mai 2018, 17:00, insgesamt 1-mal geändert.




Borg
Bronze - Status
Beiträge: 173
Registriert: Mo 14. Aug 2017, 19:52
Drucker: Anet E10, getuned
Hat sich bedankt: 0
Danksagung erhalten: 27 Mal

Hotend Temperatur wird falsch angezeigt.

Beitrag von Borg » Mi 9. Mai 2018, 16:30

Stimmt denn die Temperaturanzeige bei Raumtemperatur?

Und wie hast du gegen gemessen? Vielleicht ist ja nur deine Kontrollmessung falsch.
Folgende Benutzer bedankten sich beim Autor Borg für den Beitrag:
TrippleP
Bewertung: 14.29%



Benutzeravatar
TrippleP
Honor Member
Beiträge: 63
Registriert: Mi 28. Feb 2018, 08:03
Drucker: AM8
Slicer: Cura 3.2.1
Hat sich bedankt: 23 Mal
Danksagung erhalten: 5 Mal

Hotend Temperatur wird falsch angezeigt.

Beitrag von TrippleP » Mi 9. Mai 2018, 16:54

Bei Raumtemperatur liegen alle 3 thermistoren innerhalb 0.2°C egal an welchem port vom Anet Board
Kontrollmessung Thermistoen gegeneinander und zum Raumthermostat.

Kontrollmessung bei 180°C: Thermistoren gegeneinander, je einer am Hotbet und Hotend Sensor Anschluss.


Die Kontaktfläche im Heatblock sieht auch gut aus, keine Grate oder Unebenheiten.



Benutzeravatar
red-orb
Honor Member
Beiträge: 838
Registriert: Di 27. Jun 2017, 08:06
Wohnort: Steinweiler
Drucker: Anet A2
Slicer: S3D, Slic3r
CAD - Software: FreCAD, Tinkercad
Hat sich bedankt: 24 Mal
Danksagung erhalten: 117 Mal

Hotend Temperatur wird falsch angezeigt.

Beitrag von red-orb » Do 10. Mai 2018, 14:03

Welche Abweichung hast Du denn wenn Du den Semitec 104GT-2 also die nummer 5 konfigurierst?
Folgende Benutzer bedankten sich beim Autor red-orb für den Beitrag:
TrippleP
Bewertung: 14.29%


Gruß Kai

"Do what I do. Hold tight and pretend it’s a plan!"

Benutzeravatar
TrippleP
Honor Member
Beiträge: 63
Registriert: Mi 28. Feb 2018, 08:03
Drucker: AM8
Slicer: Cura 3.2.1
Hat sich bedankt: 23 Mal
Danksagung erhalten: 5 Mal

Hotend Temperatur wird falsch angezeigt.

Beitrag von TrippleP » Do 10. Mai 2018, 15:05

Typ5 180°C soll zu 145°C Ist (geht kein PLA durch die nozzel also plausibel ); 29°C Raumtemp wird correct angezeigt.
Typ55 180°C Soll zu 97°C ist

Jeweils gemessen mit dem Thermistor vom A8 Hotend aussen am Heatblock, angeschlossen an den Hotbed connector vom Anet Board



Benutzeravatar
red-orb
Honor Member
Beiträge: 838
Registriert: Di 27. Jun 2017, 08:06
Wohnort: Steinweiler
Drucker: Anet A2
Slicer: S3D, Slic3r
CAD - Software: FreCAD, Tinkercad
Hat sich bedankt: 24 Mal
Danksagung erhalten: 117 Mal

Re: Hotend Temperatur wird falsch angezeigt.

Beitrag von red-orb » Do 10. Mai 2018, 16:05

Ich gehe jetzt mal davon aus, dass der Thermistor 5 eventuell einen hau weg hat.
Prüf mal den Widerstand deiner beiden Thermistor bei 200°
Stell den Thermistor vom MK8 auf 200° und muss den Widerstand und dann stell den neuen auch auf 200° und miss da den Widerstand.
Ich gehe jetzt mal davon aus, dass der neue bei hohen Temperaturen mit dem Widerstand abweicht.
Folgende Benutzer bedankten sich beim Autor red-orb für den Beitrag:
TrippleP
Bewertung: 14.29%


Gruß Kai

"Do what I do. Hold tight and pretend it’s a plan!"

Benutzeravatar
TrippleP
Honor Member
Beiträge: 63
Registriert: Mi 28. Feb 2018, 08:03
Drucker: AM8
Slicer: Cura 3.2.1
Hat sich bedankt: 23 Mal
Danksagung erhalten: 5 Mal

Hotend Temperatur wird falsch angezeigt.

Beitrag von TrippleP » Do 10. Mai 2018, 17:16

Kann ich nachher mal testen. Meinst du den wieder stand wenn der thermistor 200Grad meldet oder wenn die Kontrollmessung 200 meldet?
Mich wundert nur, das ich mit dem beim v6 clone mitgelieferten Typ 13 die gleiche Abweichungen habe...

Kann es ggf auch am heatblock liegen?



Benutzeravatar
TrippleP
Honor Member
Beiträge: 63
Registriert: Mi 28. Feb 2018, 08:03
Drucker: AM8
Slicer: Cura 3.2.1
Hat sich bedankt: 23 Mal
Danksagung erhalten: 5 Mal

Hotend Temperatur wird falsch angezeigt.

Beitrag von TrippleP » Do 10. Mai 2018, 17:50

So... Ich scheine den Schuldigen gefunden zu haben... Den Heatblock!

Ich habe den Hotend Thermistor auf das nackte Heatbed gelegt und dieses auf 100°C gebracht, seht euch mal das Ergebnis an...
Thermistor.JPG
Ich bin grad etwas sprachlos...
Du hast keine ausreichende Berechtigung, um die Dateianhänge dieses Beitrags anzusehen.



Benutzeravatar
red-orb
Honor Member
Beiträge: 838
Registriert: Di 27. Jun 2017, 08:06
Wohnort: Steinweiler
Drucker: Anet A2
Slicer: S3D, Slic3r
CAD - Software: FreCAD, Tinkercad
Hat sich bedankt: 24 Mal
Danksagung erhalten: 117 Mal

Re: Hotend Temperatur wird falsch angezeigt.

Beitrag von red-orb » Do 10. Mai 2018, 17:56

Ich meinte wenn bei beiden 200° angezeigt werden zum einen und zum anderen Messen wenn bei beiden 200° durch das externe Thermometer angezeigt werden.

Aber es erschließt sich nicht wieso da ein so extremer Unterschied herkommen sollte.
Was mir aber grade einfällt hast Du den Thermistor mir Wärmeleitpaste in den Heizblock eingebaut?
Folgende Benutzer bedankten sich beim Autor red-orb für den Beitrag:
TrippleP
Bewertung: 14.29%


Gruß Kai

"Do what I do. Hold tight and pretend it’s a plan!"

Benutzeravatar
TrippleP
Honor Member
Beiträge: 63
Registriert: Mi 28. Feb 2018, 08:03
Drucker: AM8
Slicer: Cura 3.2.1
Hat sich bedankt: 23 Mal
Danksagung erhalten: 5 Mal

Hotend Temperatur wird falsch angezeigt.

Beitrag von TrippleP » Do 10. Mai 2018, 18:05

Nein ohne



Benutzeravatar
red-orb
Honor Member
Beiträge: 838
Registriert: Di 27. Jun 2017, 08:06
Wohnort: Steinweiler
Drucker: Anet A2
Slicer: S3D, Slic3r
CAD - Software: FreCAD, Tinkercad
Hat sich bedankt: 24 Mal
Danksagung erhalten: 117 Mal

Re: Hotend Temperatur wird falsch angezeigt.

Beitrag von red-orb » Do 10. Mai 2018, 19:43

Das könnte die Differenz erklären


Gruß Kai

"Do what I do. Hold tight and pretend it’s a plan!"

Benutzeravatar
th33xitus
Site - Moderator
Beiträge: 1500
Registriert: Sa 17. Dez 2016, 00:31
Drucker: Anet A8
Slicer: Slic3r / S3D
CAD - Software: Solidworks 2017
Hat sich bedankt: 96 Mal
Danksagung erhalten: 225 Mal

Hotend Temperatur wird falsch angezeigt.

Beitrag von th33xitus » Do 10. Mai 2018, 20:06

30°C delta weil Wärmeleitpaste fehlt? Wohl kaum...

Außerdem hat Wärmeleitpaste an keinem Bauteil des Heizblockes etwas zu suchen.
Die einzige Stelle die man mit Wärmeleitpaste versehen könnte wäre das M7 Gewinde welches in den Heatsink eingeschraubt wird.
Und dort befinden wir uns bereits außerhalb der "Problemzone".
Folgende Benutzer bedankten sich beim Autor th33xitus für den Beitrag:
TrippleP
Bewertung: 14.29%


Daumen hoch nicht vergessen, wenn User hilfreiche Antworten gegeben haben :)

Gebt bei jeglichen Problemen immer euren verwendeten Slicer + dessen Einstellungen, eure genutzte Firmware und etwaige Modifikationen vom Drucker an!

Benutzeravatar
red-orb
Honor Member
Beiträge: 838
Registriert: Di 27. Jun 2017, 08:06
Wohnort: Steinweiler
Drucker: Anet A2
Slicer: S3D, Slic3r
CAD - Software: FreCAD, Tinkercad
Hat sich bedankt: 24 Mal
Danksagung erhalten: 117 Mal

Re: Hotend Temperatur wird falsch angezeigt.

Beitrag von red-orb » Do 10. Mai 2018, 20:49

Naja nur irgendwoher muss ja die Differenz herkommen


Gruß Kai

"Do what I do. Hold tight and pretend it’s a plan!"

Benutzeravatar
TrippleP
Honor Member
Beiträge: 63
Registriert: Mi 28. Feb 2018, 08:03
Drucker: AM8
Slicer: Cura 3.2.1
Hat sich bedankt: 23 Mal
Danksagung erhalten: 5 Mal

Hotend Temperatur wird falsch angezeigt.

Beitrag von TrippleP » Do 10. Mai 2018, 21:24

Ich bin zu wenig Metaller um das einschätzen zu können aber es muss ja einen grund haben warum die Wärme schneller am Thermistor ankommt als sie sich im Block verteilt...

Ich bin da echt ratlos...
Ein Potentialproblem zwischen Thermistor und Heizpatrone dürfte es bei Alu ja auch nicht geben.



Benutzeravatar
red-orb
Honor Member
Beiträge: 838
Registriert: Di 27. Jun 2017, 08:06
Wohnort: Steinweiler
Drucker: Anet A2
Slicer: S3D, Slic3r
CAD - Software: FreCAD, Tinkercad
Hat sich bedankt: 24 Mal
Danksagung erhalten: 117 Mal

Re: Hotend Temperatur wird falsch angezeigt.

Beitrag von red-orb » Do 10. Mai 2018, 21:30

Wenn jetzt der Widerstand sich bei ca 200° passt dann sehe ich nur noch Marlin als Ursache.
So als wenn es die Werte nicht richtig auswerten kann.
Welche Version hast Du im Einsatz?


Gruß Kai

"Do what I do. Hold tight and pretend it’s a plan!"

Benutzeravatar
TrippleP
Honor Member
Beiträge: 63
Registriert: Mi 28. Feb 2018, 08:03
Drucker: AM8
Slicer: Cura 3.2.1
Hat sich bedankt: 23 Mal
Danksagung erhalten: 5 Mal

Hotend Temperatur wird falsch angezeigt.

Beitrag von TrippleP » Do 10. Mai 2018, 21:34

Sagen wir so, am hotend hatte ich bei 100°C schon 20°C abweichung, ausserhalb. auf dem HotBed passt es bis auf 2°....
Ebenso ist der Tempverlauf vom Hotbed und dem darauf liegenden Thermistor absolut parallel.

Daher würde ich Software, KAbel und Thermistor eigentlich ausschießen, aber kann mich natürlich auch irren



Benutzeravatar
red-orb
Honor Member
Beiträge: 838
Registriert: Di 27. Jun 2017, 08:06
Wohnort: Steinweiler
Drucker: Anet A2
Slicer: S3D, Slic3r
CAD - Software: FreCAD, Tinkercad
Hat sich bedankt: 24 Mal
Danksagung erhalten: 117 Mal

Re: Hotend Temperatur wird falsch angezeigt.

Beitrag von red-orb » Do 10. Mai 2018, 21:52

Hmm ist echt seltsam das ganze.


Gruß Kai

"Do what I do. Hold tight and pretend it’s a plan!"

Benutzeravatar
th33xitus
Site - Moderator
Beiträge: 1500
Registriert: Sa 17. Dez 2016, 00:31
Drucker: Anet A8
Slicer: Slic3r / S3D
CAD - Software: Solidworks 2017
Hat sich bedankt: 96 Mal
Danksagung erhalten: 225 Mal

Hotend Temperatur wird falsch angezeigt.

Beitrag von th33xitus » Do 10. Mai 2018, 22:07

TrippleP hat geschrieben:
Do 10. Mai 2018, 21:24
es muss ja einen grund haben warum die Wärme schneller am Thermistor ankommt als sie sich im Block verteilt...
:roll:

Löse doch mal bitte den Knoten da im Hirn. Ich habe dir im Chat schon gesagt, dass der Ansatz Quatsch ist.

Die Heizpatrone ist nahezu auf genau der gegenüberliegenden Seite vom Thermistor im Heizblock eingeschraubt.
Dazwischen befindet sich sogar noch die Düse.
Wie soll deiner Meinung nach jetzt der Wärmestrom fließen, sodass die sie angeblich schneller am Thermistor ankommt als an der Düse oder sonst wo?


Einfach um die Software mal ausschließen zu können:
Besorg dir die aktuellste Marlin bugfix und flash die mal.


Daumen hoch nicht vergessen, wenn User hilfreiche Antworten gegeben haben :)

Gebt bei jeglichen Problemen immer euren verwendeten Slicer + dessen Einstellungen, eure genutzte Firmware und etwaige Modifikationen vom Drucker an!

Benutzeravatar
lixxbox
Honor Member
Beiträge: 342
Registriert: Mi 25. Jan 2017, 15:12
Wohnort: Koblenz
Drucker: Bowden AM8+Octoprint
Slicer: Simplify3D
CAD - Software: Fusion360
Hat sich bedankt: 26 Mal
Danksagung erhalten: 59 Mal

Hotend Temperatur wird falsch angezeigt.

Beitrag von lixxbox » Fr 11. Mai 2018, 08:34

Ich bin von der Kontrollmethode, den Thermistor gegen den Heizblock zu drücken, nicht wirklich überzeugt. Hatte das mal mit einem ausrangierten Grillthermometer versucht, das ging genauso in die Hose. :mrgreen:



Benutzeravatar
TrippleP
Honor Member
Beiträge: 63
Registriert: Mi 28. Feb 2018, 08:03
Drucker: AM8
Slicer: Cura 3.2.1
Hat sich bedankt: 23 Mal
Danksagung erhalten: 5 Mal

Hotend Temperatur wird falsch angezeigt.

Beitrag von TrippleP » Fr 11. Mai 2018, 09:20

Mit dem neuesten Bugfix release, keine Änderung



Benutzeravatar
TrippleP
Honor Member
Beiträge: 63
Registriert: Mi 28. Feb 2018, 08:03
Drucker: AM8
Slicer: Cura 3.2.1
Hat sich bedankt: 23 Mal
Danksagung erhalten: 5 Mal

Hotend Temperatur wird falsch angezeigt.

Beitrag von TrippleP » Fr 11. Mai 2018, 09:22

lixxbox hat geschrieben:
Fr 11. Mai 2018, 08:34
Ich bin von der Kontrollmethode, den Thermistor gegen den Heizblock zu drücken, nicht wirklich überzeugt. Hatte das mal mit einem ausrangierten Grillthermometer versucht, das ging genauso in die Hose. :mrgreen:
Ist doch im Grunde die gleiche Vorgehendweise wie beim alten E3D Design?



Antworten

Zurück zu „Allgemeine Modifikationen“